28 lines
631 B
1
{ pkgs, mkPnpmPackage }:
2
3
mkPnpmPackage rec {
4
workspace = ./..;
5
src = ./..;
6
7
# Work around a bug with how it expects dist
8
components = [
9
"packages/core"
10
"packages/core-extensions"
11
"packages/injector"
12
"packages/node-preload"
13
"packages/types"
14
"packages/web-preload"
15
];
16
distDirs = [ "dist" ];
17
18
copyNodeModules = true;
19
buildPhase = "pnpm run build";
20
installPhase = "cp -r dist $out";
21
22
meta = with pkgs.lib; {
23
description = "Yet another Discord mod";
24
homepage = "https://moonlight-mod.github.io/";
25
license = licenses.lgpl3;
26
maintainers = with maintainers; [ notnite ];
27
};
28
}
29